Back to overview
Maintenance

Notice of MC Network Maintenance

Dec 13 at 12:55pm GMT  –  Dec 13 at 01:09pm GMT
Affected services
Proxy #1
Main Hub #1
Main Hub #2
Wildlands
Practice

Resolved
Dec 13 at 01:09pm GMT

Network maintenance has now ended, and everything has been successfully updated. Services are now back online - thanks for your patience!

Created
Dec 13 at 12:55pm GMT

The network is currently undergoing maintenance due to version updates. Services may be temporarily unavailable while we complete the update process. We’ll share an update once everything is back online.