Back to overview
Resolved

Homelab Infrastructure Maintenance

Jul 6, 2026 at 4:10pm UTC  –  Jul 6, 2026 at 6:10pm UTC
Affected services
Proxmox Host
TrueNAS
Jellyfin
Immich

Resolved
Jul 6, 2026 at 6:10pm UTC

Maintenance ended

Created
Jul 6, 2026 at 4:10pm UTC

We are currently performing scheduled maintenance across our homelab infrastructure, which supports multiple services including storage, media, virtualisation, and authentication systems.

During this maintenance window, some services may be temporarily unavailable or experience reduced performance. This is part of planned work to improve stability, apply updates, and enhance overall system reliability.

We are actively monitoring the process and will restore full service as quickly as possible.

If you need help or notice unexpected issues, please contact support via the usual support channel or dashboard contact method (once available).