Storage Migration - Immich Performance Degradation
Resolved
May 19, 2026 at 6:34am UTC
The Immich storage migration has been completed successfully.
Performance has returned to normal, and uploads, background jobs, media loading, and overall responsiveness should now be operating as expected.
Thank you for your patience during the migration.
Affected services
Created
May 18, 2026 at 9:28pm UTC
Immich is currently experiencing degraded performance while we migrate storage.
Most available system performance is being used for the migration process, so you may notice slower uploads, delayed background jobs, slower photo/video loading, and reduced responsiveness.
We are monitoring the migration and will restore normal performance once it is complete. Thank you for your patience.
Affected services